Cannot Sign Into MoviePass App on New iPhone Due to “Unauthorized Device” Error Message [Phone Number Added]

Updated 10pm PT on 9/24: Reader Mikey shared MoviePass’s phone number in the comments.  The phone number is 646-400-0801 and it is not a toll free number.


Good morning everyone, I hope your weekend is going well.  On Friday and Saturday, I spent a few hours setting up my new iPhone XS.  During the process, I tried to sign into the MoviePass app on my new iPhone but kept getting this error message: “Unauthorized Device – account in use on another device.”  Oh right, let me sign out of the MoviePass app on my old iPhone.  I went back to my new iPhone to try signing into the MoviePass app.  Same error message.  Ok, let me try deleting the MoviePass app on my old iPhone.  Unfortunately, I still got the same error message.  I decided to search on Google for a solution…

Thankfully, MoviePass has a helpful FAQ page about the “Unauthorized Device” error message.  At the bottom of the page, was the key information I needed: “If you purchase a new smartphone, your device may be switched to a different device every 30 days simply by reinstalling the MoviePass app or you can contact our Customer Experience team.”  I deleted and reinstalled the MoviePass app on my new iPhone, but still no luck.  My last resort was to contact MoviePass.  Based on reading hundreds of angry tweets about MoviePass, I was worried that I would get a response in several days or not at all.  I clicked the Submit A Request link at the top of the page.

I filled out the form, attached the screenshot of the error message from my new iPhone, verified my humanness, clicked the Submit button and prayed for a quick answer.

MoviePass uses ZenDesk for their customer service.  Based on the timestamp of the email, my request was submitted at 11:10am PT.  How long would I need to wait until I received a response?

Thankfully, I did not need to wait very long.  At 1:33pm PT, roughly 2.5 hours later, a rep from MoviePass responded to my request and told me that they would be overriding the device lock for my account, as a one time courtesy.  Sweet!  I tried to log into the MoviePass app on my new iPhone and I was successful!

I responded to the email thread at 1:36pm PT and received a response 4 minutes later at 1:40pm PT.  I must have gotten lucky to get such a quick response.  I was able to use MoviePass the same day to check in and see a movie.

As some of you may know, I recently signed up for Sinemia during their Summer Sale (3 movies for $9.99) but decided to keep my MoviePass account open since I usually see more than 3 movies per month.  If my girlfriend wants to see a movie with me, I can get one ticket via MoviePass and the other ticket via Sinemia.  If you have any questions about MoviePass, please leave a comment below.  Have a great weekend everyone!

6 thoughts on “Cannot Sign Into MoviePass App on New iPhone Due to “Unauthorized Device” Error Message [Phone Number Added]

  1. Pingback: Recap: Lyft Public Transport Integration, MoviePass Support & More - Doctor Of Credit

  2. Pingback: Sinemia's Fall Promo & Trying to Understand Cardless Activation and Membership Dates

  3. Mikey

    It’s a lot easier to call in to have the device unlocked. I was on hold for about 20 min but it was an easy explanation when I finally got to an agent and total call was under a half hour.

    Reply
    1. Grant Post author

      Oh great idea, I had no idea that MoviePass had a customer service phone number. I will try that next time I have an issue. Glad you got it resolved easily with a single call.

      Reply
      1. Mikey

        Yeah the number was 646-400-0801. Totally a “get what you pay for” situation considering its not even a toll free number (not like that really matters anymore)…

        Reply

Got something to say?